Cannot supply asset

I have enabled the asset but for some reason the “Supply” button is still greyed out and I cannot input the quantity of asset to supply. Other assets that have not been enabled correctly shows the “Enable” button in green, however when I click this asset it only shows a greyed out “Supply” button.

Am I doing something wrong? can anyone help me?

1 Like

I just had the same issue. Did you ever figure this out?

In my case, I enabled USDC. USDC shows that it’s enabled, but when I go to supply, it still requires enabling. BUT ETH for some reason is not enabled but is allowing supply (at least on the web app). WTF?

There are 2 types of Enable actually, looks like you are confusing between them. Switch, visible on front page is Enable to use as collateral. There is another type of Enable, is Enabling contract to spend an asset, and that permission also need to be granted before you can suply/borrow asset. Thus if you Enable asset to be used as collateral you still can’t supply asset until you grant necessary permission. It’s normal, you are not doing anything wrong and app is working as intended. You still need to do Enable contract to spend asset inside Supply regardless of what you did with Collateral Enable switch. The only exeption is native token, ETH, which doesn’t need additional permission.


Thanks, @Sirokko ! You cleared it up quite nicely.