Website of v2 app not loading in browser when I have exodus extension installed.

Hi all,

I have a bit of strange one but here goes. I hope I explain it clearly, english isn’t my first language.

So I haven’t used the v2-app in a few months so I might have missed a change/update. I used to stake my dai on exodus wallet and since compund left exodus I started using the v2-app to borrow and trade with my funds. I use the exodus web3 wallet to connect and this has always worked fine but after not having checked it for a while, when I returned all I get is a blank page.

Here are the things I noticed and tried:
When I turn my exodus extension off the page loads. I have tried deleting browser history and cookies, I have tried a different browser. I have tried a fresh install of browsers and I have tried multiple devices (with different browsers). I can access the app and I have plenty of other wallets installed put when I install/enable my exodus wallet I just get a blank page. I can use the v3 app and it does show funds etc. It’s just v2 that isnt working.

Anyone know what’s going?

Thanks in advance <3